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Icons 
 

Icon Meaning 

 
Caution 

 
Example 

 
Note 

 
Recommendation 

 
Syntax 

 

 

Typographic Conventions 
 

Type Style Description 

Example text Words or characters that appear on the screen. These include field 
names, screen titles, pushbuttons as well as menu names, paths and 
options. 

Cross-references to other documentation. 
Example text Emphasized words or phrases in body text, titles of graphics and tables.

EXAMPLE TEXT Names of elements in the system. These include report names, 
program names, transaction codes, table names, and individual key 
words of a programming language, when surrounded by body text, for 
example, SELECT and INCLUDE. 

Example text Screen output. This includes file and directory names and their paths, 
messages, source code, names of variables and parameters as well as 
names of installation, upgrade and database tools. 

EXAMPLE TEXT Keys on the keyboard, for example, function keys (such as F2) or the 
ENTER key. 

Example text Exact user entry. These are words or characters that you enter in the 
system exactly as they appear in the documentation. 

<Example text> Variable user entry. Pointed brackets indicate that you replace these 
words and characters with appropriate entries. 
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 Indirect Role Assignment Using HR-ORG 
Use 
The employees or users require appropriate authorizations to perform their tasks. As the 
authorization administrator, you can assign the roles required for this (single and/or composite 
roles) directly using transactions SU01, SU10, and PFCG or indirectly using the HR-ORG 
model.  

If the employee changes, you do not need to assign the role to the new employee again, but 
only the position. In this way, the new employee automatically receives the roles assigned 
indirectly through the position.  

If an employee changes position, the personnel administrator assigns a new position to the 
employee. This means that the employee loses the authorizations that belonged to his or her 
old position, and receives the authorizations for his or her new position. 

Process Flow 
There must be a maintained HR-ORG model in your company for you to be able to assign 
roles indirectly as the authorization administrator. The employees or users are each assigned 
to a position that combines their activities. You can assign authorizations in the form of roles 
to any HR-ORG object types. 

Task Areas of the HR Department and of the User Administrator 

Legend

HR structure of the HR department
Assignment by the user administrator
Attribute assignment

US

O

S

PAG

AG

O

S

AG

 
The user master comparison (transaction PFUD) evaluates these indirect role assignments 
and automatically assigns the authorizations to the users. This means that you, as the 
authorization administrator, develop activity-specific roles. These roles are then assigned to 
positions, jobs, work centers, or superordinate organizational units. 

 
If a role is assigned to a very large number of users using your link in the HR-
ORG model, it is better for performance reasons for the user master comparison 
to assign this role to the users directly using user maintenance (such as 
transaction SU10).  

To create the direct role assignments, the user master comparison uses the rules contained 
in evaluation path US_ACTGR (table T77AW) to link the role with the employee or user. The 
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rules describe how the user is determined, starting from the role, using the HR-ORG model 
links. 

The evaluation path is delivered with default values; that is, you need to modify it to suit your 
requirements. As you can assign the role to any object type, you must adjust the evaluation 
path so that the direct assignment of the role to the user can be created during the user 
comparison. As soon as a valid evaluation path is available, you can assign the roles to the 
HR-ORG object types. This means that a user assigned to a position automatically receives 
the roles defined for the position. For more information about maintaining evaluation paths, 
see Maintaining Evaluation Paths [Extern]. 

You can use HR_ORG to assign single and composite roles with and without the use of 
central user administration in accordance with the rules of the composite roles resolution. 
However, this is a local assignment; that is, the role must exist in the system in which it is to 
be assigned.  

Prerequisites 
• You have defined an active plan variant in the current client. 

• The infotype 0105 is maintained in the HR system, so that the connection between the 
employee and the user ID can be created. 

• The Customizing switch HR_ORG_ACTIVE in table PRGN_CUST is set to YES to 
activate the HR-ORG management for role administration. 

• The evaluation path US_ACTGR (table T77AW) is adjusted. 

• You have shown the Org.Management button (transaction PFCG → Goto → Settings 
→ Complete View). 

Examples 
Example 1 
In our first example, the employees (P) are assigned the positions (S) in the HR system. This 
is the usual structure of an HR-ORG model, although you can also link users directly with the 
position, without using the object type P. The user ID (US) of the user is stored using the 
infotype 0105. At the same time, the role (AG) is also assigned to the position. From this 
indirect role assignment, the user master comparison generates the direct role assignment to 
the user. See the following graphic. 

HR-ORG Model with Organizational Object Type Employee 

US

Legend:

Indirect role assignment
Direct role assignment
Attribute assignment

O

S

PAG
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Evaluation Path US_ACTGR in Table T77AW with Organizational Object Type Employee 

Seq. Number Object Specification 
of the 
Linkage 

Linkage Priority Type of the 
Linked 
Object 

40 AG A 007 * S 

50 AG A 007 * US 

70 P B 208 * US 

110 S A 008 * P 

Explanations for the Evaluation Path 

The evaluation path allows you to specify the connection between the role and user. Starting 
from the role, the user master comparison (transaction PFUD) reaches the associated 
position at sequence number 40. The connection between the position and the employee is 
described with sequence number 110. Sequence number 70 then describes the connection 
between employee and user. This corresponds to Infotype 0105. The result is the direct 
connection between the role and the determined user; that is, the role assignment. Sequence 
number 50 also displays the direct role assignments in role maintenance using the Org. 
Management button. 

Example 2 
Our second example describes a system in which the organizational object type Employee 
either does not exist or is not used. This structure usually arises when you are copying the 
HR-ORG model from an HR system to a SAP Web AS, which does not recognize the 
organizational object type Employee. Therefore, in this case, the user is assigned to the 
position, to which in turn the role is assigned. See the following graphic. 

HR-ORG Model without Organizational Object Type Employee 

Legend:

Indirect Role Assignment
Direct Role Assignment

O

S

AG US

 
Therefore there is a different evaluation path for systems with the organizational object type 
Employee to that for systems without this object type. The evaluation paths of these 
structures are in the table below.  

Evaluation Path US_ACTGR in Table T77AW without Organizational Object Type 
Employee 

Seq. Number Object Specification 
of the 
Linkage 

Linkage Priority Type of the 
Linked 
Object 

40 AG A 007 * S 

50 AG A 007 * US 

110 S A 008 * US 
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Explanations for the Evaluation Path 

This evaluation path is different from the previous path in only one way: the object type P is 
not used. The connection between the position and the employee is therefore created directly 
with sequence number 110.  

 
See also: 
Organizational Management [Extern] 

 

 Assigning a Role Indirectly 
... 

1. Choose Tools → Administration → User Maintenance → PFCG – Roles (transaction 
PFCG). 

2. Choose Goto → Settings → Total View (Organizational Management and Workflow). 

The Org.Management pushbutton is then displayed on the User tab page. 

3. Specify the role that you want to assign indirectly, and choose Display. 

4. Choose the Org.Management button on the User tab page. 

The Role: User Assignment screen appears.  

5. Switch to change mode, and choose the Create Assignment pushbutton. 

The system displays the Select processor type dialog box, in which you can select 
some or all of the following object types, depending on the evaluation path: 
position, job, organizational unit, position, work center, and user. 

 
The assignments for the User object type are then completely identical to the 
assignments maintained on the User tab page. 

6. Select the object to which the role is to be assigned. 

7. In the following dialog box, select an available object (for example, using the possible 
entries help) and choose Create. 

The assignments created in this way are called indirect user assignments, as they are 
not made directly between the user and the role.  

These indirect user assignments are stored as gray in the user display and highlighted 
in color. 

Status Display and Maintenance 
The status display in the Org.Management button shows whether you need to update the 
indirect user assignments: 

• Green: User assignments are current 

• Red: User assignments are not current, the indirectly assigned users are not 
completely displayed on the tab page. 

Comparing the Indirect Role Assignments 
You have the following options to update the assignment: 

• Choose Org.Management and then Compare indirect user assignment. 

• Perform the manual user master comparison that also automatically updates the 
indirectly assigned users. 



SAP Online Help  07.04.2003 

Users and Roles (BC-SEC-USR) 6.20 9 

• Schedule report PFCG_TIME_DEPENDENCY periodically. This report performs a 
complete comparison, consisting of HR-ORG, composite role, and profile comparisons. 

• Create a variant of report RHAUTUPD_NEW (transaction PFUD), in which the HR-
ORG Comparison indicator is set on the selection screen, and schedule this variant 
periodically. 

• Call transaction PFUD and set the indicator HR-ORG comparison  on the selection 
screen 

This means that all indirectly assigned users for which the assignment has become 
valid on the basis of the assignment period are directly assigned to the role, and all 
directly assigned users for which the assignment has become invalid are removed. 

 

See also: 
SAP Note 578271: PFCG integration of role assignment maintenance in PPOME 

 

 Indirect Role Assignment in a System Landscape 
The following scenarios are examples for the use of indirect role assignment in a system 
landscape: 
... 

• You are using indirect role assignment in every system of your system landscape. You 
may also be using Central User Administration, with which you perform role 
assignments directly in each system (the Role Assignment parameter is set to Local). 
To do this, you must distribute your HR-ORG model that you maintain, for example, in 
your HR system, to all systems (see Distribution [Page 10]). You can either maintain 
the role assignments in the HR-ORG model in the source system and distribute them 
with the model and maintain the assignments in all target systems. 

¡ Maintaining role assignments in the source system and distributing them with 
the model 

You want to have the same role assignments in every system. To achieve this, 
the used roles must exist in all systems. 

¡ Maintaining the role assignment in the target systems: 

You make individual role assignments in each system. 

HR System

CUA

Enterprise 
Edition 4.7

Local role 
assignment

HR-O
RG m

od
el 

wi
tho

ut 
ro

le 

as
sig

nm
en

t

HR-ORG model 
with or without 
role assignment

Local role 
assignment

Local role 
assignment

 

• You are using indirect role assignment only in the central system of Central User 
Administration. You maintain the HR-ORG model without role assignment, for example 
in your HR system, and distribute it to the CUA central system. Global role assignment 
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is active (the Role Assignment parameter is set to Global), meaning that you can use 
composite roles with target system-specific single roles. The indirect role assignment 
creates only local direct role assignments. In our example, in which the HR-ORG 
model was distributed to the CUA central system, these direct role assignments are 
therefore created in the CUA central system. If you now use composite roles, the 
system also creates direct assignments of the user to the single roles in the relevant 
systems, which arise from the composite role definition. 

HR System

ZBV

Enterprise 
Edition 4.7

Global Role
Assignment

HR-O
RGmod

el 

wi
tho

ut 
ro

le 

as
sig

nm
en

t

Single role assignment 
through composite role 

resolution and direct 
manual single role 

assignment for 
individual systems

 

• You are using a combination of the above scenarios, such as using a CUA central 
system with global role assignment. In this way, you can maintain role assignment for 
all systems manually. You can also distribute the HR-ORG model to all systems to 
make local indirect role assignments. This means that you can make indirect role 
assignments in every child system of the CUA using HR-ORG, although you cannot 
enter any direct role assignments manually. 

HR System

CUA

Enterprise 
Edition 4.7

Indirect, local and manual, 
global role assignment

HR-
ORGmod

el 

wi
th 

or
 w

ith
ou

t 

ro
le 

as
sig

nm
en

t

Single role assignment 
using composite role 
resolution and direct 
manual single role 

assignment for single 
systems

HR-ORG model 
role assignmentIndirect, local 

role assignment
Indirect, local 
role assignment

  

 

 Distributing the HR-ORG Model 
Use 
You want to distribute the HR-ORG model that you have created in your HR system to one or 
more systems (see scenarios [Page 9]) to use it to perform indirect role assignment in these 
systems. 
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You should usually only distribute the required objects when distributing the HR-ORG model. 
In this description, only the objects required for user administration are distributed.  

The distribution process is dependent on the following factors, which you must also consider 
later when making the filter settings for the HR-ORG model: 

• Maintaining the role assignments in the HR-ORG model: If you make the role 
assignments in the HR-ORG model in the source system and distribute them together 
with the model, use authorizations in the receiving system to ensure that no user can 
change the HR-ORG model. If you perform the distribution without links to roles, you 
should still use authorizations to ensure in the receiving system that no user can 
change the objects of the HR-ORG model. Only the role assignments may be changed. 

• Existence of the Employee organization object type: If at least one of the target 
systems does not know the employee object type (that is, it is not an HR system), the 
assignment of position to employee must be replaced by the assignment of position to 
user during the distribution process. To do this, create a Customer Exit that adds the 
position - user relationships in addition to the existing position - employee - user 
relationships. The ALE exit filters then delete the relationships that cannot be used, 
depending on the target system. 

Prerequisite 
• The 0105 infotype for the employee is maintained. 

• You have ensured that the same active plan version has the value 01 both in the HR 
system and in the target system. This parameter is in table T77S0, group PLOGI, and 
semantic abbreviation PLOGI. 

• The used users all exist in all systems (through CUA distribution or client copy). 

Process Flow 
If you are distributing the HR-ORG model with the user assignment from an HR system to an 
HR system and a non-HR system, the process flow is as follows: 
... 

1. Create the HR-ORG distribution model in the HR system [Page 12]. When doing this, 
ensure that you maintain infotype 0105 in particular. 

2. Generate partner profiles in the HR and CUA central systems [Page 13]. 

3. If one of the target systems does not know the Employee object type, create an 
outbound filter with customer exit in the HR system [Page 14]. 

4. So that you can later distribute only the changed data of the HR-ORG model, activate 
the change pointers [Page 15] and, if necessary, write the change pointers for Infotype 
0105 [Page 15] (for target systems that do not know the Employee object type). 

5. Distribute the entire HR-ORG model. [Page 16] 

6. Distribute the changes to the HR-ORG model [Page 17] 

 

See also: 

• SAP Note 200343: HR-CA-ALE: Composite SAP Note: Distribution of HR Master Data 

• SAP Note 363187: HR-CA-ALE: Initial Distribution with HRMD_A/HRMD_ABA (Tips) 

• SAP Note 200066: HR-CA-ALE: Q&A for Setting Up HR-ALE-Scenarios 

This note contains links to the QuickStart documentation for ALE and the ALE HR 
business processes. 

• SAP Note 581019: Distribute PFCG HR-ORG model for indirect role 
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 Creating an HR-ORG Distribution Model in the 
Sending System 
Use 
To be able to copy the HR_ORG model to other systems, you must first create a 
corresponding distribution model. This distribution model is a view of the HR-ORG model that 
is then distributed instead of the entire HR-ORG model. Note the settings of the outbound 
filter, especially if you are using the customer exit. 

Procedure 
... 

1. In the sending system (HR system) choose Tools → ALE and EDI → Administration → 
Runtime Settings→ Partner Profiles (transaction BD64). 

2. In change mode, choose Create Model View and enter the following data: 

Field Value 

Short text Description of the distribution model (for example: HR-ORG 
Distribution Model) 

Technical name Technical name of the distribution model (such as HR_ORG)

3. Choose Insert Message Type and enter the following data: 

Field Value 

Model view HR_ORG 

Sender Logical name of the HR system 

Receiver Logical name of the receiving system 

Message Type HRMD_ABA 

4. Expand the HR-ORG  Distribution Model node. 

5. Define a filter for the distribution model by double clicking the option No Filter Set. 

The system displays the Edit Filter dialog box. 

The filters described below reduce the distribution of the HR-ORG model to the objects 
that are significant for user administration. 

... 

a. Choose Create Filter Group and expand the Data Filtering node. 

b. Call the Edit Value List dialog box by double clicking the Infotype node. 

c. Enter the data required in accordance with the lists below using the Insert Line 
button( ), and choose Copy. 

d. Call the Edit Value List dialog box by double clicking the Object type node. 

e. Enter the data required in accordance with the lists below using the Insert Line 
button( ), and choose Copy. In addition to the required object types, you can 
also enter the object types specified in brackets. 

Filter Setting for the HR System as Target System 

§ Filter Group for Relations 

• Infotype: 1001, 0105 

• Object type: O, P, S (possible additional object types: C) 

• Type of the linked object: AG, O, P, S (possible additional object 
types: C, T, TS, UG, US, and WF) 
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§ Filter Group for Organizational Objects 

• Infotype: 1000 

• Object type: O, S (possible additional object types: C) 

 
The organizational object types defined in the filter are distributed, meaning that 
P (employee) must be retained in the filter, but not US (user). If relationships 
between the position and the user were created by the customer exit [Page 14] , 
this prevents the setting that these relationships occur in the HR system. 

If you want to distribute the relationship of the role of the HR-ORG model, you 
must include the object type AG in the filter. 

Filter Setting for non-HR Systems as Target Systems 

§ Filter Group for Relations 

• Infotype: 1001 

• Object type: O, S (possible additional object types: C) 

• Type of the linked object: US, AG, O, S (possible additional 
object types: C, T, TS, UG, and WF) 

§ Filter Group for Organizational Objects 

• Infotype: 1000 

• Object type: O, S (possible additional object types: C) 

 
The organizational object types defined in the filter are distributed, meaning that 
US (user) must be retained in the filter, but not P (employee). If relationships 
between the position and the employee and the employee and the user were 
created by the customer exit [Page 14] , this prevents the setting that these 
relationships occur in the non-HR system. 

If you want to distribute the relationship of the role of the HR-ORG model, you 
must include the object type AG in the filter. 

6. Distribute the model view by choosing Edit → Model View → Distribute to All Receiving 
Systems. 

 

 Generating Partner Profiles of the HR-ORG 
Distribution Model 
Use 
Perform these procedures both in the HR system and in the receiving system of the HR-ORG 
distribution model. 

 
Choose serial background processing for the incoming processing. In this way, 
you can avoid two background jobs being run in parallel, as this can easily 
cause update problems. 

If the system displays an error message in transaction WE02, saying that the 
object was locked, check the background processing of the IDocs. 
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Procedure 
... 

1. Choose Environment → Generate Partner Profile in transaction BD64. 

The system displays the Generating  Partner Profile screen. 

2. Specify the model view and the receiving system. 

3. Under inbound parameters, choose the option Trigger by Background Program. 

 
To be able to use background processing, you must then schedule the report 
RBDAPP01 for the message type HRMD_ABA in all receiving systems. The 
IDocs of the HR-ORG model are updated sequentially by the background 
processing. This avoids lock problems. 

4. Check the result log for the partner profile generation in the sending and receiving 
systems. 

 If message type HRMD_ABA was not generated correctly in the sending 
system, adjust the outbound processing in transaction WE20. 

i. On the Partner Profiles screen (transaction WE20), choose the partner 
profile of the sending system under Partner type LS. 

ii. Check whether message type HRMD_ABA is listed under Outbound 
parameters. 

If not, add it with Create Outbound Parameter. On the Partner Profiles: 
Outbound Parameters screen, you can specify the following data: 

 Outbound Options tab page: Message type: HRMD_ABA, process code: 
HRMD, syntax check, triggered by background program 

 Postprocessing tab page: Allowed Processor: Type: US, Processor: User 
name of the administrator, Language: EN 

If message type HRMD_ABA was not generated correctly in the receiving system, 
adjust the inbound processing in transaction WE20. 

... 

i. On the Partner Profiles screen (transaction WE20), choose the partner 
profile of the sending system under Partner type LS. 

ii. Check whether message type HRMD_ABA is listed under Inbound 
parameters. 

If not, add it with Create Inbound Parameter. On the Partner Profiles: Inbound 
Parameters screen, you can specify the following data: 

 Inbound Options tab page: Message type: HRMD_ABA, process code: 
HRMD, syntax check, triggered by background program 

 Postprocessing tab page: Allowed Processor: Type: US, Processor: User 
name of the administrator, Language: EN 

 

 Creating an Outbound Filter with Customer Exit 
Use 
If one of the target systems does not know the object type Employee, you must replace the 
relationship between the position and the employee in the HR system with the relationship 
between the position and the user. The infotype 0105 links the employee with a user ID.  
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The customer exit  time-dependently inserts the S-US relationships in addition to the S-P-US 
relationships. The ALE Filter filters out either the S-US relationships or the S-P relationships, 
depending on whether or not the system knows the object type Employee. In target systems 
with the object type Employee, the S-P-US relationships are retained, and in target systems 
without the Employee object type, the S-US relationships are retained. It is therefore vital that 
you have maintained the filter settings correctly. 

Procedure 
... 

1. Call the transaction CMOD in the HR system. 

2. Create a project and assign the enhancement RHALE001 to it by choosing 
Enhancement Assignments. 

3. Insert a filter by choosing the Components pushbutton and double clicking 
EXIT_SAPLRHA0_001. 

4. Enter the include name RPRGN_XHALU01 in include ZXHALU01 of function module 
EXIT_SAPLRHA0_001. 

If the include is not yet available to you, import the correction instructions from SAP 
Note 581019. 

5. Generate the function group. 

6. Activate the include, the function, and the project. 

 

 Activating Change Pointers 
Use 
You can activate change pointers in the HR system to avoid distributing the entire structure 
when you make changes to the HR-ORG model, and distribute instead only the changes that 
you have made. 

Procedure 
... 

1. In the Implementation Guide (IMG, transaction SALE), choose Modeling and 
Implementing → Master Data Distribution → Replication of Modified Data → Activate 
Change Pointers - Generally. 

2. Set the activation status Activate Change Pointers - Generally, and save your entry. 

3. Choose the activity Activate Change Pointers for Message Types. 

4. Set the active indicator for the message type HRMD_ABA. 

5. Save your entries. 

 

 Writing Change Pointers for Infotype 0105 
Use 
If you are using change pointers and at least one target system for the distribution of the HR-
ORG model does not know the object type Employee, changes to the infotype 0105 are not 
distributed to this target system. However, change pointers for the infotype 0105 are 
recorded. As the infotype 0105 is not distributed, however, the associated change pointers 
are ignored. You must therefore explicitly write change pointers for the linked position with a 
dynamic task in this case. 
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If you change infotype 0105, the dynamic task is automatically started when these changes 
are saved. It writes change pointers for the positions to which the employee is assigned. The 
change pointers of the position are taken into account during the next distribution process. As 
the Customer Exit adds the links to the user, the changes to infotype 0105 are also taken into 
account.   

Procedure 
... 

1. Create the program Z_RPRGN_WRITE_CHANGE_POINTER in accordance with the 
instructions in SAP Note 581019. 

2. Activate the program in Customizing. To do this, in the Implementation Guide 
(transaction SPRO), choose Personnel Management → Personnel Administration → 
Customizing Procedures → Dynamic Actions. 

3. Create the following table entry by choosing New Entries: 

ITy FC No. A Variable Function Part 

0105 00 0 F pa0105_change( Z_RPRGN_WRITE_CHANGE_POINTER) 

 

For more information about dynamic actions, see the documentation for this IMG activity. 

 

 Distribute HR-ORG-Model (Initial Distribution) 
Use 
Perform the following steps in order with report RHALEINI: 
... 

1. Make a preselection of the data to be distributed on the selection screen of the report. 

2. The report automatically filters the data with the filters defined in the distribution model. 

3. The report automatically filters the data with the outbound filter of the Customizing exit. 

4. The report distributes the data that has been selected to the receiving system. 

Procedure 
... 

1. Start the report RHALEINI with transaction SA38. 

2. Specify the following data: 

Field Value: 

Plan variant 01 

Object type  

Object ID Relevant HR structure 

Evaluation period All 

Evaluation value O-S-P Staff assignments along 
organizational structure 

With this path you can choose the 
data that is relevant for user 
administration. 

Transfer mode Insert 

This mode inserts the data to be 
distributed by overwriting  
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Receiver Partner Number Logical name of the receiving system 

3. Choose Execute. 

 

 Distribute Changes to the HR_ORG Model 
Use 
With this procedure, you can distribute only the delta of changed data for the HR-ORG model 
to the receiving systems. 

Procedure 
... 

1. Call transaction BD21 or schedule this report transaction as a background job. 

2. Choose message type HRMD_ABA and then Execute. 

 
With the report RHALECPS, you can evaluate the change pointer. 

 


